NVME

Wikis > NVME

NVME Storage Driver

The NVM Express or Non-Volatile Memory Host Controller Interface (NVMe) storage driver for ArcaOS supports NVME hardware version 1.2 and later. The driver can handle up to 8 adapters with up to 16 namespaces on each adapter.

Please read the ReadMe before installing and using this software.

Please also see the Multiple disk type considerations page.

Requirements and limitations

This driver requires advanced interrupts as provided by the PSD running in advanced interrupt mode (mode 2). This means that it requires the SMP kernel and the PSD running in the default mode. This driver will probably not work with the W4 kernel, without the PSD, or when using the /VW or /PIC switches.

  • As of June 2022 data show that SK Hynix Gold P31 devices have problems and may not work, or may cause other things in the system to not work. This wiki will be updated if future data changes the results.

Support and Submitting Tickets

Reporting bugs and requesting new features is done through the ticket system. You can view existing tickets, add comments to them and create new tickets using the corresponding buttons at the top of every page. If you want to submit a new bug or request a feature, please use the Search function first to make sure there is no ticket for the same problem already created.

This entry last updated: by David Azarewicz